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Instructions for preparing a new MobileDOAS system 

Updated 7/1/2024, Christoph Kern (ckern@usgs.gov) & Allan Lerner (alerner@usgs.gov) – USGS-VDAP 

 

Creating a new MobileDOAS system consists of 2 parts: (1) setting up a new laptop with all the software 

you need, and then (2) configuring the MobileDOAS software to operate properly with the new 

spectrometer.  

 

Preparing a new computer for MobileDOAS 

- Boot the computer. If this is a new Windows 11 installation, you will need to go through several 

settings:  

o When asked for a Microsoft account, sign in with no@thankyou.com and an arbitrary 

password. This should allow you to proceed without setting up an account. 

o Recommend using “NOVAC” for the computer name, and “Mobile DOAS” for the 

username. No password. 

- If you haven’t already done so, connect to the internet 

- Run windows update multiple times until Windows is reasonably up to date (this will involve 

multiple computer resets) 

- In Search/Control Panel, go to “Turn Windows features on or off” 

o Click to enable the box next to “.NET Framework 3.5 (includes .NET 2.0 and 3.0). Let 

Windows download the required files and do the installation (download takes a while). 

- Open a Windows Explorer folder. Click “…” -> Options -> View. Disable “Hide extensions for 

known file types”. Click Apply to Folders. 

- Go to “Add or Remove Programs” and remove pre-installed bloatware. Things like those listed 

below can all be removed: 

o Dell Optimizer 

o Dell Optimizer service 

o Disney+ 

o Family 

o Feedback Hub 

o Movies and TV 

o News 

o Solitaire Collection 

o Spotify Music 

o Xbox 

o Xbox Live 

- Go to Startup Apps and disable unnecessary high-impact programs from auto starting upon 

power-on (e.g., Microsoft Teams, Microsoft OneDrive) 
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- Install the following software (create a directory for these files: C:\Users\Mobile 

DOAS\Documents\Install Files) 

o 7Zip  (“7z1701-x64.exe”) 

o Chrome 

o FileZilla 

▪ After installing, open FileZilla and click Help -> Check for updates. Update to the 

latest version (might require multiple updates). 

o GoogleEarthPro 

o GpsInfo 

▪ This one doesn’t need to be installed, but simply copied to the desktop. Once 

copied, right click and open Properties. Click Compatibility -> Change settings for 

all users. Check “Run this program as an administrator” and apply the setting. 

o GhostScript  ('gs922w64.exe”) 

▪ When prompted, generate the Windows fonts. 

o DOASIS 

▪ Once installed, open DOASIS. Click Extras -> Options -> Spectrum Defaults. Click 

“Use spectrum’s file name on file open”. Change the Default spectrum size to 

2048. 

▪ Close DOASIS. It will ask you whether you want to save all changes. Select “No” 

(this refers to the spectra, not the settings). When prompted whether DOASIS 

should automatically check for updates, select “No”. 

o MATLAB Runtime R2020a 

o mDOAS 

▪ Simply copy the mDOAS_v3.xx directory directly to C:\ 

o Notepad++  (“npp.6.9.2.Installer.exe”) 

▪ Start Notepad++ and let it do the updates it wants. 

o Ocean Optics OmniDriver version 2.37 (some newer versions don’t work with all 

spectrometers!) 

o Putty 

o WinSCP 

▪ Start WinSCP, click Help -> Check for Updates, and do them if necessary. 

Clean up the desktop view by unpinning unneeded shortcuts on taskbar 

 

Installing and configuring the latest version of MobileDOAS 

- Copy the MobileDOAS files to C:\MobileDOAS. 

o Double check that the folder “StandardCrossSections” is in the same directory as the 

MobileDOAS.exe file 

o Pin this folder to Quick Access for convenience 

- Create a subdirectory with the serial number of your spectrometer 

o e.g. C:\MobileDOAS\FLMS21214 

- Create a shortcut to MobileDOAS.exe on the desktop 

- Open MobileDOAS 
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- If the main MobileDOAS screen doesn’t fit on the laptop screen, right-click on the desktop, go to 

display settings, and reduce the “scale” until it does fit. 

- Connect the GPS and spectrometer to the laptop. 

- Label the USB ports that you are using for each device (or at least remember which ones you are 

using and label them later). Spectrometer port can be labeled with spectrometer serial number 

to clearly indicate which spectrometer is intended to be used with the laptop. 

Calibrating the Spectrometer 

- Go outside with the setup. Connect fiber and telescope to the spectrometer and aim at the sky. 

- Click Control -> View spectrometer output. Choose a suitable exposure time (max intensity ~70-

80%) and save a spectrum of the sky (example filename: “sky_yyyymmdd.std”). 

- Cover the telescope and record a dark spectrum using the same exposure time. Save it (example 

filename: “dark_yyyymmdd.std”). 

- Stop spectra measurements 

- Open the sky spectrum in the DOASIS program. 

o Using the marker, find out which pixel has the highest light intensity. Make a note of the 

pixel (channel) number. 

o Click Data -> Calibration Assistant. Click Next 

o By typing numbers into the Channel and Wavelength fields, add the following 3 entries 

to the list: 

▪ Channel 0, Wavelength 280 nm 

▪ Channel 1000, Wavelength 350 nm 

▪ Channel 2040, Wavelength 420 nm 

o Click Next. Select Poly Order 2. Click Next several times. Apply the Calibration to the 

“Current Spectrum”.  

o Save the rough calibration in std format, e.g. filename “sky_calibrated.std”. 

- Go back to MobileDOAS. Click Analysis -> Calibrate spectrometer -> Wavelength Calibration.  

o For Measured Spectrum, enter the uncalibrated sky spectrum.  

o For Dark enter the dark spectrum.  

o In Settings -> Setup,  

▪ Select the “High Resolved Solar Spectrum” (e.g., 

C:\MobileDOAS\StandardCrossSections\SOLARFL_296-440nm.xs) 

▪ For “Initial Calibration”, select the roughly calibrated sky spectrum 

(“sky_calibrated.std”). Click Open 

▪ Click “Fit a Super Gaussian Instrument Line Shape”. Use default wavelength 

range (320–350 nm) 

▪ Click “Also include O3_Voigt_223K (vac)” 

▪ Click OK 

o Run the calibration by clicking “Run” in the bottom right. This process can take ≥ 1 

minute or so. 

o Once the calibration has completed, click Save Calibration and save the calibration in the 

spectrometer subdirectory you created earlier as “#####_AutoCal.std”, replacing the 

######… with the serial number of your spectrometer. 
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o Now click Save References at the bottom right. For Prefix (in the “Instrument Name” 

window), enter the serial number of the spectrometer. Leave suffix blank. “Create and 

Save” the references to the spectrometer subdirectory.  

o Exit the Calibration Dialog and go back to the main MobileDOAS screen 

o Minimize MobileDOAS momentarily and load the SO2 reference you just created in 

DOASIS. Check to see if it looks reasonable and contains wavelengths along the top axis 

spanning from approximately 280 to 420 nm.  

o Using the marker, find the Channels that correspond to 310 nm and 340 nm. Make a 

note of these, rounded to the nearest whole number.  

▪ Note: use wavelength values in the Marker information rather than the top axis, 

which suffers from issues of linearly approximating a non-linear relationship of 

channel # to wavelength. Don’t be alarmed by this 

o Copy the newly created spectrometer calibration files to a backup directory someplace 

+/- send copies to Christoph Kern to add to his archive of reference spectra  

Finishing Configuration 

o Go back to MobileDOAS. Click Configuration -> Operation Setting 

o In the Spectrometer Dialog, use these settings: 

▪ USB-Connection 

▪ N Channels: 1 

▪ Set Point Temp: -10 

▪ Offset Removal: 50 to 150 

▪ Exposure Time: Adaptive 

▪ Intensity at channel: Enter the pixel (channel) with the highest intensity that you 

determined earlier. 

▪ Should be: 65% of maximum 

▪ Saturation: 50% to 80% 

▪ Save a spectrum every 2000 ms 

▪ Audio: No thanks (unless you want it) 

o In the Configuration -> Operation Setting -> GPS Dialog: 

▪ Select “Use GPS-Receiver” 

▪ Serial port: The serial port must match the virtual COM port number of the USB-

Serial adapter connected to the GPS. To find this, go to the Windows Device 

Manager, expand Ports (COM & LPT), and find the “Prolific USB-to-Serial Comm 

Port”. This will be followed by the number you need. [If the device is not found, 

try a computer restart, and if still not found maybe try alternative GPS units] 

▪ Alternatively, there is an option within MobileDOAS software to locate the GPS 
COM port under “Control -> Test the GPS”, which will identify the COM port and 
baud rate (takes a couple of minutes to complete). 

▪ Baudrate: 4800 

o In the Configuration -> Operation Setting -> Evaluation Dialog: 

▪ In the Fit Parameters, enter the pixel (channel) range that corresponds to 310 to 

340 nm. You made note of it earlier, right? 

▪ Polynomial: keep as 5 
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▪ In Misc., select “Start with instrument calibration” 

▪ Click on existing References in the list and “Remove Reference” to clear the list. 

▪ Click Insert Reference and successively insert the SO2, O3 and Ring references 

you just created for the spectrometer, in that order. 

o Skip the Directory Dialog and go straight to Configuration -> Operation Setting -> 

Calibration: 

▪ High Resolved Solar Spectrum path:  

• The autocalibration requires the directory “StandardCrossSections” to 

be located in the same folder as the MobileDOAS executable (.exe) file. 

• The StandardCrossSections folder must contain high-resolution solar, 

SO2, O3, and Ring spectra (.xs files) and an associated .xml file. 

• Double check that this High Resolved Solar Spectrum path is correctly 

set to the “SOLARFL_296-440nm.xs” file in the StandardCrossSections 

folder. 

▪ Initial Calibration: choose the #####_AutoCal.std spectrum you created earlier. 

It should be in the spectrometer subdirectory. Click Open 

▪ Instrument Line Shape: again choose “Fit a super Gaussian…” Use default 

wavelength range (330–350 nm) 

▪ References: click the box “Generate references and use for evaluation” 

▪ Click Save 

o Restart MobileDOAS for the updated configuration file to be applied.  

 

- SO2 test cells: You should be done, but it’s a good idea to test things with an SO2 gas cell. Start 

MobileDOAS and click the green arrow start button. The software will tell you what to do. Hold 

the gas cells in front of the telescope and see if it works. Check View -> Spectrum Fit to see if the 

fit looks good, especially for gas cells with high SO2 concentrations. 

 

 

Great job!        
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MobileDOAS components 

1. Laptop 

2. Spectrometer (e.g., FLAME or AVANTES) + cable 

3. Fiber (+1 spare)   

a. Fiber details: Ocean Insight, part# QP600-2-UV-BX 

b. UV/VIS, 600 um fiber core diameter, BX jacketing, 2 meters length, QSMA connector 

types 

4. Telescope 

5. GPS + connection converting cable 

6. Carrying case 
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Telescope Assembly 

Components  (in component box in warehouse; Edmund Optics product numbers): 

A. Filter BP Col Hoya U-330 25.4x2.5mm T   (46437;  #R5000946666-22195) 

B. Lens PCX-UV 20x40 UV-AR CTD   (49967;  #R5000821434-21204) 

C. C-mount extension tube 50mm   (54632;  #R5000800103-21166) 

D. C-mount 25/25.4 mm thin lens MT   (56353;  #R5000594130-19208) 

E. C-mount 20mm thin lens MT   (54618;  #P000001344999-21167) 

F. C-mount fine focus tube   (03625;  #R5000583883-19149) 

G. C mount fiber adapter housing   (66385;  #R5000571044-19130) 

H. C-mount SMA fiber adapter   (63946;  #P000001198926-18234) 

 

 
 

Assembly Steps 

1. Remove fiber cable screw from (H) and insert screw into (G). Can discard origin screw holder 

2. Connect (G) to (F) 

3. Remove inner retaining ring in (E) with spanner wrench or small screwdriver 

4. Insert planar convex lens (B) with flat side down (towards screw/base) 

5. Replace inner retaining ring. Make tight. Connect (E) to (F) 

6. Add UV filter (A) to (D). Remove outer portion of (D) to expose inner retaining ring and place UV 
filter, re-insert inner retaining ring. Tighten and reassemble. Connect (D) to (E)  

7. Attach final 50mm tube (C) 

8. Tighten all connections as much as possible 

9. Use a reference telescope to match the telescope length positions by adjusting (F) for good focal 
point onto fiber. A good telescope length from top of telescope to where screw enters the base 
of components is ~114 mm (4.49”).  

10. Tighten set screw when at good telescope length (need very tiny hex key ~1.27 mm [0.05”]) 

11. Wrap all connections in electrical tape to secure and to help with waterproofing 
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GPS USB connection construction 

If using a Garmin 18x PC GPS receiver, it will be necessary to modify the wiring for power and 

communications. One option is to use the 5V supplied by a computer USB port to power the receiver 

and use a USB-Serial converter to enable communication via USB as well. The most elegant solution for 

this is to route the 5V power to PIN 9 on the DB9 connector of the USB serial converter, then wire the 

DB9 female connector on the GPS side accordingly. In order not to power the PC board of the USB serial 

connector in an unwanted way, it’s probably best to cut the lead leading away from PIN 9 using a knife 

(indicated by white arrow in picture below). Note: Never use a USB Serial connector modified in this 

way for any other purpose as this could cause damage to both external devices and any computer to 

which it is attached! We then cut the GPS cable on the antenna side of the Y splitter, and wire a DB9 

connector to the GPS as shown in the diagram below. 
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Power can be supplied to a serial GPS by splicing out the 5V coming from the USB port and connecting it to PIN 9 on the DB9 
connector. Make sure to cut the lead leading away from PIN 9 on the PC board (indicated by white arrow). Never use a USB 

Serial connector modified in this way for any other purpose! 

 

 

Wiring diagram for connecting a DB9 connector to a Garmin 18x GPS. The colors shown on the DB9 connector side refer to 
the wire colors on a DIGI DB9F/BareWire cable. 

 


